Domain Registration Issue
Incident Report for Sitelio
Resolved
All services are up and running at this time. We appreciate your patience while we worked to resolve the issue with domain registrations. As always, thank you for your patience!

-The Builder Team
Posted 11 months ago. Jan 31, 2018 - 21:43 EST
Identified
We've identified the issue preventing domains from completing registration. We are continuing to work toward a resolution. As always, we appreciate your patience!
Posted 11 months ago. Jan 31, 2018 - 20:27 EST
Update
We appreciate your patience as we continue to look into this issue. We will provide additional updates as we have them. Thank you!
Posted 11 months ago. Jan 31, 2018 - 18:41 EST
Investigating
We are currently experiencing issues/difficulty registering domains, our engineer teams are engaged. Thank you for your patience.
Posted 11 months ago. Jan 31, 2018 - 17:38 EST