Webmail Access
Incident Report for Sitelio
Resolved
The issue has been resolved and all email services should be restored. Thank you for your patience while we worked towards a resolution!
Posted about 1 year ago. Sep 18, 2017 - 16:54 EDT
Identified
We're currently working on restarting our email servers in an effort to restore access to webmail. We thank you for your patience!
Posted about 1 year ago. Sep 18, 2017 - 15:48 EDT
Investigating
We are currently aware of an issue affecting access to customer Webmail accounts. We are working with our engineering team to identify the root cause of the problem and will continue providing updates as we have them. Thank you for your patience!
Posted about 1 year ago. Sep 18, 2017 - 15:21 EDT