Phone Support Outage
Incident Report for Sitelio
Resolved
This issue has been resolved and our phone team is now available! Thank you for your patience during this time.
Posted Nov 14, 2018 - 10:07 EST
Investigating
We are currently experiencing an issue with our phone support center that is preventing us from answering your calls. We are working closely with our engineers to resolve this issue. We apologize for this inconvenience and look forward to speaking with you soon. We will provide an update shortly. Thank you for your patience!
Posted Nov 14, 2018 - 09:28 EST
This incident affected: Support.