Paypal Payment Issues
Incident Report for Sitelio
Resolved
This incident has been resolved. We appreciate your patience while we worked to resolve this issue with Paypal. Thank you for your patience! Have a great weekend.
Posted 16 days ago. Aug 02, 2019 - 17:16 EDT
Update
At this time, we are still working with Paypal to resolve this issue and will provide an update as soon as possible.
We appreciate your patience, as always. Thank you!
Posted 16 days ago. Aug 02, 2019 - 16:40 EDT
Identified
We are currently aware of a 3rd-Party issue which is impacting our ability to take payments using Paypal. We are working towards a resolution as quickly as possible and we appreciate your patience.
Posted 16 days ago. Aug 02, 2019 - 13:27 EDT
This incident affected: Billing.